ZOC Online Help Topic:

Menu Commands → Logging Menu

ZOC maintains multiple different logging methods. There are two memory logging mechanisms which are found in the View Menu. The log menu itself features permanent logging functions, i.e. logging to disk file and printer.

Log to File writes incoming data to a file on disk. Log to Printer sends incoming data to the printer. The call log records time, duration, cost and file transfers (see Options→Program Settings→Special Files).

The Logging menu controls file logging and printer logging.

       
Log to File
 

This function turns file logging on or off. The same can be done by clicking the log file name in the Status Line and can be done remotely if your host supports the DC2/DC4 logging protocol (see Options→Session Profile→Logging options).

Log to Printer
 

Sometimes it is handy to have part of a session sent to the printer. This is possible by enabling this function before receiving the data (e.g. before reading a mail).

To print text that has already been received, mark it in the scrollback (View Menu), which copies it to the clipboard, and then choose Print Clipboard from the Edit Menu.

Set Logfile Name
 

Set the name of the current log file. The name can be automatically selected from the host directory when connecting to a host (when starting ZOC the log file gets its name from Options→Session Profile→Logging options). You may use special placeholders for the name as described in placeholder codes and in Options→Session Profile→Logging.

Use Default Logfile Name
 

This sets the log file to the file defined in Options→Session Profile→Logging options.

Delete Log Files
 

Since you can build log file names that contain the current date you might end up with a lot of log files. Using this function lets you delete log files you do not need any more. Selecting this function will open a file requester in which you can select one or more files which will be deleted if you press OK.

Show Logfiles Folder
 

Opens the folder in which the log files are stored.

 

 
← Back to Menu Commands